Power Outage — all online services impacted
Resolved
The BCIT website and all ITS systems are now back online.

Unless students have already received communication from their instructor otherwise, classes, exams, and assignments will take place as scheduled for November 13.
Posted Nov 13, 2023 - 09:03 PST
Update
Due to the November 11 power outage, the BCIT website and ITS systems continue to be offline. Students should work directly with their instructors on contingency planning for classes, assignments, and exams scheduled for November 12.

In the event students are not able to connect with their instructors for instruction related to assignments, classes, or exams scheduled for November 12 they will not be penalized.
Posted Nov 12, 2023 - 12:55 PST
Update
As of 9:00am November 12th, specialty equipment required to fix the electrical distribution infrastructure damaged by the recent storm is still en route to BCIT. Once the equipment arrives, our electrical vendor and BCIT teams will work as quickly as possible to restore power to our data centre. Until then, all BCIT online services, including network and phone, will remain offline until further notice.
Posted Nov 12, 2023 - 09:06 PST
Update
As of this evening, electrical crews are onsite working with BCIT staff to restore power distribution to the BCIT data centre. Until power is restored, all online services, including network, will remain offline until further notice. We will provide an update at 9:00am, November 12th.
Posted Nov 11, 2023 - 18:54 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 11, 2023 - 14:09 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 11, 2023 - 09:20 PST
Identified
A wind storm has disabled power at the BCIT Burnaby Campus. We are working with BC Hydro to restore power as soon as possible. All online services including the network are offline until further notice.
Posted Nov 11, 2023 - 08:49 PST
This incident affected: Main BCIT Website, BCIT Central Login, Network Services, Banner Self-Serve, Banner 9, AppsAnywhere, myVPN (VPN), AccessAnywhere (VPN), Workspace, myBCIT Website, myBCIT Webmail (Students, Faculty and Staff), The Loop (Intranet), Learning Hub (D2L), ShareSpace, SFTP ShareIn/Out, Network File Storage, BCIT Reporting, Jabber, Phone Systems, Cherwell Service Management, ChromeRiver, Archibus, Computer Lab Workstations, and Commons.bcit.ca.