Inbound my.bcit.ca email outage
Resolved
This issue has been identified and resolved.
Posted Nov 10, 2023 - 13:51 PST
Investigating
Inbound emails to my.bcit.ca email accounts are currently not being delivered. IT Services are aware of the issue and are working towards a resolution.
Posted Nov 10, 2023 - 07:40 PST
This incident affected: myBCIT Email (SMTP/IMAP).