Student Email / mail.my.bcit.ca Issues

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 15:08 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 17, 2025 - 13:55 PDT
This incident affected: myBCIT Webmail (Students, Faculty and Staff) and myBCIT Email (SMTP/IMAP).