Banner 9 not responding for multiple customers and Service Desk Analysts
Resolved
Incident with Banner 9 has been resolved
Posted May 03, 2021 - 12:56 PDT
Investigating
Issue is currently being investigated
Posted May 03, 2021 - 09:49 PDT
This incident affected: Banner 9.