BCIT Website Search Unavailable

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 16:05 PST

Monitoring

The availability of Search on the BCIT Website is returning although the situation is continuing to be monitored by our team
Posted Feb 20, 2026 - 15:20 PST

Identified

While the search feature on the BCIT Website continues to be unavailable, please make use of BCIT AI assist as an alternative.

https://www.bcit.ca/search-ai-assist/
Posted Feb 20, 2026 - 13:50 PST

Investigating

Our website search provider is currently experiencing an outage, we are working with them to resolve the issue as quickly as possible. Until resolved our website search will be unavailable.
Posted Feb 20, 2026 - 13:16 PST
This incident affected: Main BCIT Website.