Data Centre Shutdown - 2026-Feb-28 to 2026-Mar-01

Scheduled for Feb 28, 18:00 PST  -  Mar 1, 04:00 PST

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 12, 2026 - 10:08 PST

Scheduled

From: 6:00 PM Saturday, 2026-Feb-28
To: 4:00 AM Sunday, 2026-Mar-01

Data Centre Shutdown for UPS Replacement (Facilities Project)

There will be no access to locally hosted applications or services during this outage. Some cloud applications may still be available.
Posted Jan 29, 2026 - 07:55 PST
This scheduled maintenance affects: Network Services, Banner Self-Serve, Banner 9, AppsAnywhere, myBCIT Website, myBCIT Webmail (Students, Faculty and Staff), myBCIT Email (SMTP/IMAP), Network File Storage, BCIT Reporting, Computer Lab Workstations, Millennium, and Apporto.