Adobe Software Requests Unavailable

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 11:51 PDT

Investigating

new requests for Adobe software licensing can not be processed while our systems undergo maintenance.

This message will be updated as more information is available

We apologize for any inconvenience and thank you for your patience
Posted Aug 26, 2025 - 11:26 PDT
This incident affected: Adobe.