Partial BCIT Website Outage
Resolved
This incident has been resolved.
Posted Nov 10, 2023 - 08:53 PST
Identified
A subset of apps on the BCIT Website are currently unavailable due to maintenance:
redirect.bcit.ca
i.bcit.ca
Checkbot
Test Center Forms

Functionality will be restored Nov 10, 8:30am
Posted Nov 09, 2023 - 16:31 PST
This incident affected: Main BCIT Website.