@BCIT.CA Public Web Page Intermittent Connection issues due to volume in registration

Resolved

This incident has been resolved.
Posted May 21, 2025 - 12:56 PDT

Update

issues with the @bcit.ca website have been resolved
Posted May 21, 2025 - 12:55 PDT

Investigating

Due to the high volume in contacts during Flex learning registration this morning, the following are experiencing intermittent connection issues:
... Programs and Course search from the Main BCIT website (bcit.ca/study)
... searching for courses from the Student Self Service Portal
Posted May 21, 2025 - 09:21 PDT
This incident affected: Main BCIT Website and Banner 9.