Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Dec 01, 2024 - 11:12 PST
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Nov 30, 2024 - 19:09 PST
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Nov 29, 2024 - 21:51 PST
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Nov 29, 2024 - 21:50 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 29, 2024 - 12:29 PST
Scheduled
From: 6:00 pm - Friday, November 29 2024 To: 6:00 pm - Sunday, December 01 2024 Note: this work is being scheduled outside the maintenance window due to requirements for testing and verfication.
Work being done: Banner maintenance
Campuses affected: All Campuses
What does it mean for you?
Access to the following systems/services will be unavailable.
Students and Staff • myBCIT Webmail • Online Self Service (via myBCIT) • Online Registration through www.bcit.ca • Course and program finder through www.bcit.ca • Course Outlines through www.bcit.ca
Action needed: none
Staff • Online Registration through www.bcit.ca • Course and program finder through www.bcit.ca • Access to Employee Self Service and Employee Dashboard
Posted Nov 20, 2024 - 13:14 PST
This scheduled maintenance affected: Banner Self-Serve, Banner 9, myBCIT Website, and myBCIT Webmail (Students, Faculty and Staff).