Ellucian Email - sent on 2025-Oct-06

Resolved

We have since disabled the notification process in all our environments to ensure no further messages are inadvertently sent out. Apologies again for the confusion and thank you for your patience as we work to prevent this from happening in the future.
Posted Oct 09, 2025 - 11:02 PDT

Update

We are continuing to investigate this issue.
Posted Oct 09, 2025 - 11:00 PDT

Investigating

IT Services discovered that due to a change made over the weekend (October 4/5, 2025), inadvertently triggered the delivery of notifications that should have been sent April 14/15, 2025. Those notifications had been backlogged due to an error in configuration.

We would like to assure you that a breach did not occur, and your data has not been sold.

We have since disabled the notification process in all our environments to ensure no further messages are inadvertently sent out. Apologies again for the confusion and thank you for your patience as we work to prevent this from happening in the future.
Posted Oct 09, 2025 - 10:59 PDT
This incident affected: myBCIT Email (SMTP/IMAP).