BCIT Employee Email is being restored
Resolved
The BCIT employee email has been restored.
Posted Apr 10, 2021 - 07:50 PDT
Update
A fix has been implemented and we are monitoring the results. Most of the mail service has been restored but there may still be some minor interruptions.
Posted Apr 09, 2021 - 22:31 PDT
Monitoring
A fix has been implemented and we are monitoring the results. Most of the mail service has been restored but there may still be some minor interruptions.
Posted Apr 09, 2021 - 21:01 PDT
Update
BCIT Employee email (@bcit.ca) continues to be unavailable. The Mail team is investigating and working to resolve the issue. The next update will be at 9PM this evening.
Posted Apr 09, 2021 - 17:29 PDT
Update
BCIT Employee email (@bcit.ca) continues to be unavailable. The Mail team is investigating and working to resolve the issue.
Posted Apr 09, 2021 - 16:43 PDT
Update
We are continuing to investigate this issue.
Posted Apr 09, 2021 - 14:56 PDT
Update
We are continuing to investigate this issue.
Posted Apr 09, 2021 - 13:08 PDT
Investigating
Exchange Server is currently not available. BCIT Employee email (@bcit.ca) is down. Exchange team is working on this issue.
Posted Apr 09, 2021 - 13:08 PDT
This incident affected: BCIT Employee Email.