myBCIT Maintenance Requiring anOutage

Scheduled for Apr 18, 18:00 - 19:30 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 15, 2026 - 11:38 PDT

Scheduled

myBCIT and my.bcit.ca email will be unavailable for a brief period during this maintenance period.

For direct access to your student record please:
• Log in to bss.bcit.ca using your Student Number (A0*******) and password.

For direct access to the Learning Hub please:
• Log in to learn.bcit.ca using your my.bcit.ca email address and password.
Posted Apr 15, 2026 - 11:36 PDT
This scheduled maintenance affects: myBCIT Website, myBCIT Webmail (Students, Faculty and Staff), and myBCIT Email (SMTP/IMAP).