Inbound and outbound email messages may be intermittently delayed when sending through Exchange Online
Resolved
Service restored
Posted Apr 17, 2024 - 13:28 PDT
Update
We are continuing to investigate this issue.
Posted Apr 17, 2024 - 12:52 PDT
Update
We are continuing to investigate this issue.
Posted Apr 17, 2024 - 11:08 PDT
Investigating
Users report that they can't send or receive messages at all. This issue occurs in all Exchange Online connection methods. This is a nation-wide issue affecting all Outlook Online users in Canada. Microsoft is working on this issue. Sorry for any inconvenience.
Posted Apr 17, 2024 - 10:38 PDT
This incident affected: BCIT Employee Email.