Student Email
Resolved
Issue has been identified and resolved:
Users previously experiencing missing email should have their mailboxes restored completely.
Posted Nov 13, 2023 - 13:49 PST
Investigating
The IT department is currently investigating reported problems with the my.bcit.ca email service.
Posted Nov 13, 2023 - 09:56 PST
This incident affected: myBCIT Webmail (Students, Faculty and Staff) and myBCIT Email (SMTP/IMAP).