Banner 9 not responding for multiple customers and Service Desk Analysts
Resolved
Banner 9 is again functional
Posted Jan 19, 2021 - 16:08 PST
Investigating
Banner 9 not responding for multiple customers and Service Desk Analysts - No ETA for resolution at this time
Posted Jan 19, 2021 - 15:12 PST