Banner 9 not responding for multiple customers and Service Desk Analysts
Resolved
This incident has been resolved.
Posted May 03, 2021 - 09:27 PDT
Investigating
Banner 9 is again functional
Posted May 03, 2021 - 08:52 PDT
This incident affected: Banner 9.